Nvidia: todo iba bien hasta la consola (bug)

Hace algún tiempo había documentado un bug del driver propietario para linux nvidia, dicho bug (para todo < 9631) causaba un fallo al ejecutar beryl donde las ventanas se quedaban "vacias o en negro" indicando un fallo en el manejo de la nvram (la memoria de video de la tarjeta); dicho bug ha sido parcialmente "corregido" en las versiones 97xx.

Ayer instalé el driver 9755, el cual como dije, "parcialmente" corrige el fallo y puedo cargar más ventanas a lo que además suma un mejor control sobre la libGL (obteniendo una aceleración constante en los efectos); que maravilla!, voy a tener a beryl activo "por siempre"! …
presiono CTRL+ALT+F1 … y … pummm!

Nuevo Bug: el controlador se va a falla imposibilitando salir a modo virtual console (la pantalla se pone negra y a veces en un caleidoscopio de colores); tambien ocurre cuando mandas a apagar el equipo, el shutdown de las X causa que la pantalla se ponga negra y no puedas ver lo que está ocurriendo.
Realmente las X no se cuelgan, pues presionar CTRL+ALT+F7 vuelves a la pantalla (bueno, a veces); tambien tienes acceso a la PC via SSH y la puedes reiniciar con CTRL+ALT+DEL; sin embargo, es engorroso tener un driver que se cree que está en Windows (no te deja ir a consola virtual ni tener más de una X levantada).
El bug está "poco" documentado en el foro oficial de nvidia (nvnews) sin embargo, si levantamos al linux con la opción vga=normal (en el menu del grub, presionen la tecla A, escriban al final del boot del kernel (ej: kernel /boot/vmlinuz-2.6.20) el bug no se sucede, sin embargo, no se logran resoluciones "aceptables" (como 1024×768 a @75hz o 1280×1024 @60hz); ver beryl a 800×600 no es de mi gusto …

bueno, "esperemos" que este fallo sea corregido en futuras versiones del nvidia driver (98xx??) …

Acerca de phenobarbital

http://about.me/phenobarbital

Publicado el 1 abril 2007 en Linux, PlanetaLinux. Añade a favoritos el enlace permanente. 7 comentarios.

  1. Hola Jesus yo tenia ese problema pero lo resolvi colocandole en el xorg.conf

    Option “UseDisplayDevice” “DFP”

    Saludos

  2. Gracias por la Acotación Gregory, si con el 9755 no tienes problemas de ir a las consolas virtuales podrías explicar que framebuffer tienes instalado?, que opciones activas en el xorg?,useDisplayDevice simplemente dice que dispositivo usar (en mi caso DFP-0) y es autodetectado por mi driver:
    NVIDIA(0): Option “MetaModes” “1440×900,1280×1024;1366×768,1366×768;1280×800,1280×800;1152×864,1152×864;1280×768,1280×768;1024×768,1024×768;1280×600,1280×600;1024×600,1024×600;800×600,800×600;768×576,768×576;640×480,640×480”
    (**) NVIDIA(0): Option “UseDisplayDevice” “DFP-0

    Y en efecto, el problema persiste, que version de nvidia tienes?, tiene turbocache?, es pci-express o agp?, hay varios factores que afectan el procedimiento.

    Que distribución tienes y que opciones tienes en el grub? …

    En mi caso, el problema persiste y he hecho un downgrade a la version 9631 que al menos es mucho más estable…

  3. Hola Jesús:

    No tengo framebuffer
    Es Agp FX 5950
    No uso Grub
    Y lo de las pantallas negras y eso con el beryl me pasó en Slackware 11

    Ya no uso Slack😦

  4. No son pantallas negras, el bug de pantallas negras es otro, este bug tiene que ver con la imposibilidad en algunos modelos de acceder a las consolas virtuales, las X se van a fallo o simplmenente aparecen pantallas de colores sin posibilidad de acceder a la consola; en este caso la culpa no es de beryl porque ocurre estando o no activo el beryl (incluso en xfce) y solo si tienes un driver 97xx.

  5. Yo uso el driver 1.0-9755 con una GeForce Go 6150 de 256 mb en ubuntu 7.04 con beryl y me pasa lo mismo, en algunas ocasiones las ventanas negras y lo de las terminales virtuales, a mi me aparece pantalla negra con cuadritos de colores y no me permite nada mas, si me regresa a las X, estas no se caen pero como dices es como estar en windows

  6. saludos, una consulta. Tengo un WinXP c/sp2 instalado y completamente operativo. no tiene ni unmes de vida desde que lo formatie. le instale un Sw de emulación: VMware Workstation (o virtual machine, como lo prefieran) y dentro de éste le instale el FEDORA CORE 5. Todo estaba super chever ahsta que por sugerencia del SW me pidió que instale el SO en un SCSI y no IDE. ahi comenzaron los problemas, bueno habilitandolo, quitandolo y al final optando por un IDE para instalarlo, lo hice correr, ya esta listo pero ahora me surge un nuevo inconveniente: cualdo quiero activar las consolas viruales (ctrl+alt+fn) no me sale ninguna y las necesito con urgencia. alguien puede darme una sugerencia porfis. gracias

  7. Un Downgrade de las nvidia a la version 9631 soluciona el problema de las no consolas o de los fallos de renderizado.
    Tal vez algun dia a nvidia se le ocurrirá postear la solución, mientras tanto, es contraproducente usar la 9755 a menos que te guste el modo “windows” de estar siempre en X sin posibilidad de irse a uan consola …

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: